通达信股票指标(更新中)

由于本人需要,特此将股票量化指标代码收集使用,仅供学习交流,请勿用于商业用途!

1.庄散线副图

指标概览:

图片[1]来自星星-Www.FromStar.Cn通达信股票指标(更新中)来自星星-Www.FromStar.Cn来自星星

指标用法: 庄线上穿散户线是买入持股阶段,反之下穿是卖出观望阶段。

指标代码:

庄筹线:EMA(WINNER(C)*70,5), COLORRED ,LINETHICK2; 

散筹线:EMA((WINNER(C*1.1)-WINNER(C*0.91))*80,3), COLORGREEN ,LINETHICK2; 

KS13:=(C-SMA(C,13,1))/SMA(C,13,1)*(-100); 

AAA:=REF(KS13,1)>13 AND REF(KS13,1)/KS13>1.23 AND C/REF(C,1)>1.03;

海底活鱼:IF(AAA AND REF(C,1)<COST(1),30,0),COLORWHITE ,LINETHICK2;

STICKLINE(庄筹线>散筹线,庄筹线-1,散筹线+1,1,0), COLOR00FFFF;

海底捞活鱼:=CROSS(5,庄筹线) AND 散筹线< 20;

AA1:=REF(庄筹线,30)> 40 OR REF(庄筹线,20)> 40;

BB1:=CROSS(28,庄筹线) AND 散筹线> 40 AND AA1=1;

CC:=REF(散筹线,1)> 散筹线 AND REF(庄筹线,1)< 庄筹线 AND 庄筹线> 30 AND 散筹线> 30 AND REF(庄筹线,1)-REF(庄筹线,2)> 3.535;

DD:=COUNT(REF(散筹线,1)> REF(庄筹线,1),5); 

鸡雀升天:=CROSS(庄筹线,散筹线) AND CC=1 AND DD>=5;

2.第一财经主图

注意:该指标需调整参数,如下图所示

图片[2]来自星星-Www.FromStar.Cn通达信股票指标(更新中)来自星星-Www.FromStar.Cn来自星星

指标概览:

图片[3]来自星星-Www.FromStar.Cn通达信股票指标(更新中)来自星星-Www.FromStar.Cn来自星星

指标用法:按上面要求正确设置参数N、M,导入代码后,买入卖出标识会出现在K线图中,简单明了。

指标代码:

高1:=REF(HHV(H,150),3);

低1:=REF(LLV(L,150),3);

H1:=高1-(高1-低1)*0.191;

H2:=高1-(高1-低1)*0.382;

H3:=高1-(高1-低1)*0.5;

H4:=高1-(高1-低1)*0.618;

H5:=高1-(高1-低1)*0.809;

{顶:REFDATE(高1,DATE),POINTDOT,COLORWHITE;}

%19:=REFDATE(H1,DATE),POINTDOT,COLORYELLOW,LINETHICK3;

%38:=REFDATE(H2,DATE),POINTDOT,COLORMAGENTA,LINETHICK3;

%50:=REFDATE(H3,DATE),POINTDOT,COLORBLUE,LINETHICK3;

%61:=REFDATE(H4,DATE),POINTDOT,COLORRED,LINETHICK3;

%80:=REFDATE(H5,DATE),POINTDOT,COLORWHITE,LINETHICK3;

AA05:MA(C,5),LINETHICK3,COLORBLUE;

五日乖离率:=(C-AA05)/AA05*100;

BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;

速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);

加速度5:=EMA((速度5-REF(速度5,1)),3),NODRAW;

IF(BB05>30 AND AA05>REF(AA05,1), AA05,DRAWNULL),LINETHICK3,COLORRED;

AA10:MA(C,10);AA20:=MA(C,20);

BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;

IF(BB05<0 AND AA05<REF(AA05,1), AA05,DRAWNULL),LINETHICK3,COLORGREEN  ;

AA30:MA(C,30);

三拾日乖离率:(C-AA30)/AA30*100,NODRAW;

VAR1:=(AA20-AA30)>REF((AA20-AA30),1) AND AA20>REF(AA20,1) AND AA30>REF(AA30,1);

VAR2:=(AA30-AA20)<REF((AA30-AA20),1) AND AA20<REF(AA20,1) AND AA30<REF(AA30,1);

BB30:=ATAN((AA30/REF(AA30,1)-1)*100)*180/3.1416;

IF(BB30>15 AND AA30>REF(AA30,1), AA30,DRAWNULL),LINETHICK3,COLORFF00FF,COLORCYAN;

强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);

加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND AA05>REF(AA05,1)  AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA10>REF(AA10,1) AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1),10) ;

清仓:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>AA30 OR O>AA30) AND AA05<REF(AA05,1)  AND 三拾日乖离率<REF(三拾日乖离率,1) AND AA10<REF(AA10,1),10);

DRAWTEXT(加仓 ,LOW*0.98,'←加仓'),COLORRED;

JC:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND AA10>REF(AA10,1) ;

减仓:=FILTER(JC,10);

MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;

买入:=FILTER(MR,10);

DRAWTEXT(减仓,HIGH*1.02,'←减仓'),COLORCYAN;

DRAWTEXT(买入,LOW*0.98,'←买入'),COLORYELLOW;

VAR21:=MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW));

VAR3:=ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100);

MV:=(VAR21+VAR3)/AMOUNT*VOL*100*50;

3.MACD优化指标副图(启动点)

指标概览:

图片[4]来自星星-Www.FromStar.Cn通达信股票指标(更新中)来自星星-Www.FromStar.Cn来自星星

指标用法:此指标为MACD优化后的指标,启动点为黄柱加小手,黄柱越长买入的参考性越高。

指标代码:

 {启动点}



DIF:EMA(CLOSE,12)-EMA(CLOSE,150);

DEA:EMA(DIF,9);

MACD:(DIF-DEA)*2,COLORSTICK;

启动点:=MACD<0 AND MACD>REF(MACD ,1) AND REF(MACD ,1)<REF(MACD ,2)

AND REF(MACD ,2)<REF(MACD ,3)

AND REF(MACD ,3)<REF(MACD ,4);

STICKLINE(启动点,0.4,MACD,2,0),COLORYELLOW;

STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,1.8,0),COLOR000055;

STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,1.1,0),COLOR000099;

STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,0.6,0),COLOR0000BB;

启动点A:0,COLORYELLOW;

DRAWICON(启动点,2,11);

4.六趋势共震,周日线结合找起涨点 神奇指标 看盘专用

指标概览:

图片[5]来自星星-Www.FromStar.Cn通达信股票指标(更新中)来自星星-Www.FromStar.Cn来自星星

指标说明:

1、指标由经久不衰的六项经典指标组成,MACD,KDJ,RSI,LW&R,BBI及ZLMM。

2、当某指标出现金叉,拐点画一个买入红箭头。当某指标出现死叉,拐点画一个卖出绿箭头。

3、红箭金叉趋势向上,绿箭死叉预示趋势向下。当六项指标同时发出红箭头时买入待涨,也就是投资回报大于投资付出!反之亦然,趋势一目了然!

4、出现多于三个向上的红箭头,表示趋势转强!向上的箭头越多,趋势越强!

5、出现多于三个向下的绿箭头,表示趋势转弱!向下的箭头越多,趋势越弱  

周线与日线结合,会找到起涨点。

多看多悟,大道至简!

用法简单,多悟多看,必有收获。

指标代码:

DIFF:=EMA(CLOSE,8)-EMA(CLOSE,13);

  DEA:=EMA(DIFF,5);

  A1:=DIFF>DEA;

  MACD金叉:IF(A1,1,0),COLORYELLOW;

  RSV1:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;

  K:=SMA(RSV1,3,1);

  D:=SMA(K,3,1);

  DRAWICON(K>D,2,1);

  DRAWICON(K<D,2,2);

  DRAWTEXT(ISLASTBAR=1,2,'.KDJ'),COLORFFFFFF;

  A2:=K>D;

  KDJ金叉:IF(A2,2,0),COLORYELLOW;

  LC:=REF(CLOSE,1);

  RSI1:=(SMA(MAX(CLOSE-LC,0),5,1))/(SMA(ABS(CLOSE-LC),5,1))*100;

  RSI2:=(SMA(MAX(CLOSE-LC,0),13,1))/(SMA(ABS(CLOSE-LC),13,1))*100;

  DRAWICON(RSI1>RSI2,3,1);

  DRAWICON(RSI1<RSI2,3,2);

  DRAWTEXT(ISLASTBAR=1,3,'.RSI'),COLORFFFFFF;

  A3:=RSI1>RSI2;

  RSI金叉:IF(A3,3,0),COLORYELLOW;

  RSV:=-(HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,13))*100;

  LWR1:=SMA(RSV,3,1);

  LWR2:=SMA(LWR1,3,1);

  DRAWICON(LWR1>LWR2,4,1);

  DRAWICON(LWR1<LWR2,4,2);

  DRAWTEXT(ISLASTBAR=1,4,'.LWR'),COLORFFFFFF;

  A4:=LWR1>LWR2;

  LWR金叉:IF(A4,4,0),COLORYELLOW;

  BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;

  DRAWICON(CLOSE>BBI,5,1);

  DRAWICON(CLOSE<BBI,5,2);

  DRAWTEXT(ISLASTBAR=1,5,'.BBI'),COLORFFFFFF;

  A5:=CLOSE>BBI;

  BBI金叉:IF(A5,5,0),COLORYELLOW;

  MTM:=CLOSE-REF(CLOSE,1);

  MMS:=100*EMA(EMA(MTM,5),3)/EMA(EMA(ABS(MTM),5),3);

  MMM:=100*EMA(EMA(MTM,13),8)/EMA(EMA(ABS(MTM),13),8);

  DRAWICON(MMS>MMM,6,1);

  DRAWICON(MMS<MMM,6,2);

  DRAWTEXT(ISLASTBAR=1,6,'.MTM'),COLORFFFFFF;

  A6:=MMS>MMM;

  MTM金叉:IF(A6,6,0),COLORYELLOW;

  涨买入:IF((A1 AND A2 AND A3 AND A4 AND A5 AND A6) AND REF(A1 AND A2 AND A3 AND A4 AND A5 AND A6,1)=0,7,0),COLORBLUE,LINETHICK2;

  上涨:IF(A1 AND A2 AND A3 AND A4 AND A5 AND A6,7,0),COLORBLUE,LINETHICK2;

5.股市雷达主图

指标概览:

图片[6]来自星星-Www.FromStar.Cn通达信股票指标(更新中)来自星星-Www.FromStar.Cn来自星星

指标说明:本公式有板块所属,各种财务数据,并且操盘信号提示清晰。

指标代码:

A:=(3*C+L+O+H)/6;
 X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
 14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
 +7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
 REF(A,20))/210;
 RCC:=DYNAINFO(3);
 S2:=SMA(C,3,1);
 S6:=SMA(C,5,1);
主力成本:EMA(X,13),COLORFF00FF,LINETHICK0;
短期底部:LLV(HIGH,30),LINETHICK0,COLORFFCC00;
 MA5:=MA(C,5);
 MA10:=MA(C,10);
 MA30:=MA(C,30);
 FA:=BARSLAST(CROSS(MA10,MA5)) AND CROSS(MA5,MA10);
 FB:=FA AND MA5>MA30 AND MA10>MA30 AND MA10>REF(MA10,1);
 DRAWTEXT(FB,L-0.58,'★红牛'),COLORRED;
 V1:=EMA(CLOSE,5);
 V2:=EMA(EMA(CLOSE,90)*1.01,10);
 DRAWTEXT(CROSS(V1,V2),V1+0.05,'牛起步'),COLOR00FF00;
 VAR1:=LLV(LOW,21);
 VAR2:=HHV(HIGH,21);
 AK1:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 100),5);
 AK:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 50),13);
 AB:=CROSS(AK1,AK);
 DRAWTEXT((AB = 1),(LOW * 0.99),'○牛窝'),COLORYELLOW;
 AA1:=AMOUNT/V;
 BB1:=L<AA1*0.9;
 CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
 DD1:=L<MA(C,5)*0.921;
 EE1:=V<MA(V,5)*1.5;
老鼠仓:=BB1 AND CC1 AND DD1 AND EE1,LINETHICK0,COLOR0099FF;
 DRAWTEXT(老鼠仓,L*0.99,'老鼠仓'),COLOR0099FF;
 VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
 VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);
 DRAWTEXT(FILTER((VAR4AA>90),45),(LOW)*(0.93),'★大胆搏 '),COLOR00FFFF;
 DRAWTEXT(FILTER((VAR4AA>90),35),(LOW)*(0.99000001),'★加仓'),COLOR00FFFF;
 A1AA:=9;
 A2AA:=(REF(CLOSE,A1AA+1)<CLOSE);
 DRAWTEXT(FILTER((A2AA>-0.5),84),(HIGH)*(1.05),'小心变盘'),COLORFFFFFF;
 VAR6:=REF(C,1);
 VAR7:=SMA(MAX(C-VAR6,0),6,1)/SMA(ABS(C-VAR6),6,1)*100;
 DRAWTEXT(CROSS(82,VAR7),H*1.01,'注意风险'),COLORYELLOW;
DRAWTEXT_FIX(1,0.00,0.00,0,'  急跌必反弹,急涨必回调;回落不破则加仓,回落跌破该减仓;反弹突破看量能,反弹不过该出货;下跌找支撑,上涨看压力;支撑位置整理必突破;压力位置整理必回调'),COLORRED;


{价:}
{JC1:=(REF(C,3)+REF(C,5)+REF(C,7)+REF(C,8)+REF(C,13)+REF(C,21))/6;
参考价1:SMA(JC1,5,1),CIRCLEDOT,COLORGREEN;
IF(C>=参考价1,参考价1,DRAWNULL),CIRCLEDOT,COLOR0000FF;}
PH:=TROUGHBARS(2,5,1);
LL:=HHV(H,PH);
TJ1:=LL=HIGH AND LL<REF(LL,1);{//=1}
TS:=SUMBARS(TJ1,2);
TJ:=PEAKBARS(2,5,1)=1 AND TS>=PH;
DRAWICON(TJ,HIGH*1.01+0.02,2);
警告灯:IF(TJ,HIGH*1.008,DRAWNULL),CROSSDOT,LINETHICK2,COLORCYAN;
PL:=BARSLAST(TJ);
支撑:IF(BARSLAST(TJ1),
REF(LOW,BARSLAST(TJ1)),DRAWNULL),COLOREA91B5;
压力:IF(BARSLAST(TJ),REF(HIGH,PL),DRAWNULL),COLORYELLOW;
TJ_2:=LOW>REF(REF(LOW,TS),PL);
DRAWTEXT(ISLASTBAR,压力,'压力'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,支撑,'支撑'),COLOREA91B5;
HIGHN:=10;LOWN:=10;HIGHDISPLAY:=0;LOWDISPLAY:=0;ZGDISPLAY:=0;MADISPLAY:=0;
AA:=REF(H,HIGHN)=HHV(H,2*HIGHN+1);
QY:=BACKSET(AA,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN+1);
DRAWICON(CC,H*1.02,2);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBU:=IF(DDD,REF(H,DDD),H);{顶部}
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
DINGBU1:=REF(DINGBU,DDD+1);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDD+1);
GDCS2:=CONST(DINGBUTS1);
DINGBU2:=REF(DINGBU1,DDD+1);
MM:=IF(CURRBARSCOUNT>GDCS2,0,1);
DRAWLINE(CURRBARSCOUNT=GDCS2,H,ISLASTBAR,REF(H,GDCS2-1),1),COLOR0055FF,POINTDOT;
DRAWLINE(CURRBARSCOUNT=GDCS1,H,ISLASTBAR,REF(H,GDCS1-1),1),COLORYELLOW,POINTDOT;
AAS:=REF(L,LOWN)=LLV(L,2*LOWN+1);
QY1:=BACKSET(AA1,LOWN+1);
CS1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN+1);
DRAWICON(CC1,L*0.98,1);
DS1:=BARSLAST(CC1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
YDB:=IF(DD1,REF(L,DD1),L);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=CONST(DDTS1);
ZDB:=REF(YDB,DD1+1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=CONST(DDTS2);
低点支撑:DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1) COLORRED,LINETHICK2;
STARDAY:=IF(DDCS2<GDCS2,DDCS2,GDCS2);


所属板块:=STRCAT('所属板块: ',STRCAT(STRCAT(STRCAT('[行业]-',HYBLOCK),STRCAT(' [地域]-',DYBLOCK)),STRCAT(' [概念]-',GNBLOCK)));
总股本:=STRCAT(STRCAT('总股本: ',CON2STR(TOTALCAPITAL/1000000,2)),'亿');
流通盘:=STRCAT(STRCAT(' 流通盘: ',CON2STR(CAPITAL/1000000,2)),'亿');
全流通:=STRCAT(' 全流通: ',CON2STR((CAPITAL/1000000)/(TOTALCAPITAL/1000000),2));
市值:=STRCAT(STRCAT(' 流通市值: ',CON2STR((CAPITAL/1000000)*C,2)),'亿');
上市天数:=STRCAT(' 上市天数: ',CON2STR(FINANCE(42),0));
股本市值:=STRCAT('股本市值: ',STRCAT(STRCAT(STRCAT(STRCAT(总股本,流通盘),全流通),市值),上市天数));
主收同比:=STRCAT(' 主收同比: ',CON2STR(FINANCE(44),2));
市盈率:=STRCAT('市盈率: ',CON2STR(C/FINANCE(33),2));
市销率:=STRCAT(' 市销率: ',CON2STR(C/(FINANCE(20)/FINANCE(1)),2));
市净率:=STRCAT(' 市净率: ',CON2STR(C/FINANCE(34),2));
毛利率:=STRCAT(' 毛利率: ',CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2));
净利润率:=STRCAT(' 净利润率: ',CON2STR(FINANCE(30)/FINANCE(20)*100,2));
现金流:=STRCAT(' 现金流: ',CON2STR(FINANCE(25)/FINANCE(1),2));
利润同比:=STRCAT(' 利润同比: ',CON2STR(FINANCE(43),2));
DRAWTEXT_FIX(ISLASTBAR,0.003,0.26,0,市盈率);
DRAWTEXT_FIX(ISLASTBAR,0,0.31,0,市销率);
DRAWTEXT_FIX(ISLASTBAR,0,0.36,0,市净率);
DRAWTEXT_FIX(ISLASTBAR,0,0.41,0,毛利率);
DRAWTEXT_FIX(ISLASTBAR,0,0.46,0,现金流);
DRAWTEXT_FIX(ISLASTBAR,0.1,0.26,0,主收同比);
DRAWTEXT_FIX(ISLASTBAR,0.1,0.31,0,净利润率);
DRAWTEXT_FIX(ISLASTBAR,0.1,0.36,0,利润同比);
{业绩}
净资收益率:=STRCAT(' 净资收益率: ',CON2STR(FINANCE(29)/FINANCE(19)*100,2));
主营利润率:=STRCAT(' 主营利润率 ',CON2STR(FINANCE(23)/FINANCE(20)*100,2));
当前业绩:=STRCAT('当前业绩: ',STRCAT(STRCAT(净资收益率,毛利率),主营利润率));
{主图显示}
DRAWTEXT_FIX(ISLASTBAR,0.005,0.06,0,所属板块),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.12,0,股本市值),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.18,0,当前业绩),COLORGREEN;

总额:=AMOUNT;
买:=IF(O=C AND (C-REF(C,1))/REF(C,1)*100>9.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));
买%:=买/AMOUNT*100;
流入:=AMOUNT*买%/10000000000;
流出:=AMOUNT/100000000-流入;
净流:=(流入-流出);
总额3:=SUM(AMOUNT,3);
流入3:=SUM(流入,3);
流出3:=SUM(流出,3);
净流3:=SUM(流入-流出,3);
总额5:=SUM(AMOUNT,5);
流入5:=SUM(流入,5);
流出5:=SUM(流出,5);
净流5:=SUM(流入-流出,5);
总额10:=SUM(AMOUNT,10);
流入10:=SUM(流入,10);
流出10:=SUM(流出,10);
净流10:=SUM(流入-流出,10);
画:=CONST(FINDHIGH(总额10,0,190,1));
DRAWTEXT_FIX(1,0.71,0.07,0,'净流(亿):'),COLOR8080FF,COLORWHITE;
DRAWTEXT_FIX(1,0.78,0.05,0,'1日'),COLOR8080FF,COLORWHITE;
DRAWTEXT_FIX(1,0.83,0.05,0,'3日'),COLOR8080FF,COLORWHITE;
DRAWTEXT_FIX(1,0.88,0.05,0,'5日'),COLOR8080FF,COLORWHITE;
DRAWTEXT_FIX(1,0.93,0.05,0,'10日'),COLOR8080FF,COLORWHITE;
DRAWNUMBER_FIX(1,0.78,0.10,0,CONST((净流))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.83,0.10,0,CONST((净流3))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.88,0.10,0,CONST((净流5))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.93,0.10,0,CONST((净流10))),COLORYELLOW;

股东人数:=FINANCE(8);
人均持股:=ROUND(FINANCE(7)/FINANCE(8));
DRAWTEXT_FIX(1,0.14,0.65,1,'股东人数:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.14,0.75,1,'人均持股:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.2,0.65,1,股东人数),COLORWHITE;
DRAWNUMBER_FIX(1,0.2,0.75,1,人均持股),COLORWHITE;
X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;
X2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积金代替}
X3:=FINANCE(23)/FINANCE(10)*3.3;
X4:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}
X5:=FINANCE(20)/FINANCE(15)*0.999;
Z值:=X1+X2+X3+X4+X5;
DRAWTEXT_FIX(1,0.85,0.01,1,'财务预警:'),COLORRED;
DRAWTEXT_FIX(Z值<1.2,0.838,0.11,1,' ●重 警●'),COLORLIRED;
DRAWTEXT_FIX( BETWEEN(Z值,1.2,2.6),0.838,0.11,1,' ○轻 警○'),COLOR0099FF;
DRAWTEXT_FIX(Z值>2.6,0.838,0.11,1,' ◎无 警◎'),COLORLIGREEN;


LC:=REF(CLOSE,1);
HD:=(HIGH-REF(HIGH,1));
LD:=(REF(LOW,1)-LOW);
DMP:=SUM(IF(((HD>0) AND (HD>LD)),HD,0),10);
DMM:=SUM(IF(((LD >0) AND (LD>HD)),LD,0),10);
TR1:=SUM(MAX(MAX((HIGH-LOW),ABS((HIGH-REF(CLOSE,1)))),ABS((LOW-REF(CLOSE,1)))),10);
PDI:=((DMP*100)/TR1);
MDI:=((DMM*100)/TR1);
ADX:=MA(((ABS((MDI-PDI))/(MDI+PDI))*100),5);
RSI5:=((SMA(MAX((CLOSE-LC),0),5,1)/SMA(ABS((CLOSE-LC)),5,1))*100);
AV:=(RSI5+ADX);
DXR:=(((ADX+REF(ADX,5))/2)+RSI5);
WR10:=((100*(HHV(HIGH,10)-CLOSE))/(HHV(HIGH,10)-LLV(LOW,10)));
NEWVOL:=(RSI5-WR10);
PX:=AV+NEWVOL;
DRAWTEXT(CROSS(PX,0),L*0.98,'  必赚');
DRAWICON(CROSS(PX,0),L*0.98,1);

AAA:=CONST(HHV(H,90));  
A74:=MA(CLOSE,20); 
A75:=(CLOSE > MA(CLOSE,5)); 
A76:=(MA(CLOSE,5) > MA(CLOSE,10)); 
A77:=(CLOSE > MA(CLOSE,10)); 
A78:=(MA(CLOSE,5) > MA(CLOSE,20)); 
A79:=(CLOSE > MA(CLOSE,20)); 
A710:=REF(A74,1); 
A711:=(A74 > A710); 
AVX:=(((((IF(A75,10,(0 - 10)) + IF(A76,10,(0 - 10))) + IF(A77,10,(0 - 10))) 
+ IF(A78,10,(0 - 10))) + IF(A79,10,(0 - 10))) + IF(A711,10,(0 - 10))); 
DSLX:=(CLOSE / INDEXC); {分析家公式网 WWW.70822.COM 整理}
DSLX1:=MA(DSLX,5); 
DSLX2:=MA(DSLX,10);  
V10:=MA(VOL,5); 
V11:=MA(VOL,10); 
T1:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0)); 
T2:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0)); 
T3:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 > V2)) AND (DSLX < DSLX1)),1,0)); 
T4:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 <= V2)) AND (DSLX < DSLX1)),1,0)); 
T5:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0)); 
T6:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0)); 
T7:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0)); 
T8:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0)); 
T9:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0)); 
T10:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0)); 
T11:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0)); 
T12:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0)); 
T13:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0)); 
T14:=CONST(IF( C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0)); 
T15:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0)); 
T16:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0)); 
T17:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 >= V2)),1,0)); 
T18:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 >= V2)),1,0)); 
T19:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 < V2)),1,0)); 
T20:=CONST(IF(C>200 AND (CROSS(1,AVX) AND (V1 >= V2)),1,0)); 
T21:=CONST(IF(C>200 AND (CROSS(1,AVX) AND (V1 < V2)),1,0)); 
T22:=CONST(IF(C>200 AND (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)),1,0)); 
T23:=CONST(IF(C>200 AND (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)),1,0)); 
T24:=CONST(IF(C>200 AND (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)),1,0)); 
T25:=CONST(IF(C>200 AND (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)),1,0)); 
DRAWTEXT_FIX(C>O,0.01,0.01,0,' 分析家公式网WWW.70822.COM'),COLOR666666;
DRAWTEXT(T1=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.3) 

,'量能理想,明显走强,中线参与,仓位在2/3左右'),COLORFF00FF ; 
DRAWTEXT(T2=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.3) 
,'走势趋强,还显不足,短线进场,仓位在1/2左右'),COLORFF00FF ; 
DRAWTEXT(T3=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.3) 
,'量价良好,没有明显走强,短线进场,仓位1/2左右'),COLORFF00FF ; 
DRAWTEXT(T4=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.3) 
,'形态尚可,量能不足,未完全走强,短线参与,仓位1/3左右'),COLORFF00FF ; 
DRAWTEXT(T5=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.3) 
,'形态变坏,重仓者减持大半,清仓者观望'),COLORFF00FF ; 
DRAWTEXT(T6=1 AND CURRBARSCOUNT=70,AAA*0.98 
,'随大盘一起下跌,明显缩量走势,考虑到风险,减持或清仓'),COLORFF00FF ; 
DRAWTEXT(T7=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.3) 
,'该股放量下跌,走势明显偏弱,离场观望'),COLORFF00FF ; 
DRAWTEXT(T8=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.3) 
,'该股缩量下跌,走势偏弱,离场观望。'),COLORFF00FF ; 
DRAWTEXT(T9=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.3) 
,'该股形态良好,强势明显,量能充足,可以继续持有'),COLORFF00FF ; 
DRAWTEXT(T10=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.3) 
,'上行趋势不变,强势依然,量能开始转弱,注意风险'),COLORFF00FF ; 
DRAWTEXT(T11=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.3) 
,'该股仍然具备上涨潜力,但股性偏弱,可考虑减仓'),COLORFF00FF ; 
DRAWTEXT(T12=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.3) 
,'该股走势趋弱,量能不足,减持大部分筹码'),COLORFF00FF ; 
DRAWTEXT(T13=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.3) 
,'该股形态不佳,注意成交量的变化,目前不适合参与'),COLORFF00FF ; 
DRAWTEXT(T14=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.3) 
,'趋势不明,股价偏弱,注意量能变化,目前不宜参与'),COLORFF00FF ; 
DRAWTEXT(T15=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.3) 
,'有走强迹象,但量能不足,趋势不明,不适合操作'),COLORFF00FF ; 
DRAWTEXT(T16=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.3) 
,'该股走势太弱,没有参与价值。'),COLORFF00FF ; 
DRAWTEXT(T17=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.3) 
,'大盘理想,有明显走强迹象,中线参与,仓位在2/3左右'),COLORFF00FF ; 
DRAWTEXT(T18=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.3) 
,'如前期经过一轮下跌,最佳买点,前期有过一段涨幅需谨慎'),COLORFF00FF ; 
DRAWTEXT(T19=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.3) 
,'考虑短线进场,仓位在1/2左右,一旦量能放大,加仓买入'),COLORFF00FF ; 
DRAWTEXT(T20=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.3) 
,'大盘形态走坏,重仓者可以减去大部分仓位。'),COLORFF0000 ; 
DRAWTEXT(T21=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.3) 
,'大盘缩量调整,注意风险,短线清仓观望。'),COLORFF0000 ; 
DRAWTEXT(T22=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.3) 
,'大盘走势良好,量能理想,可以继续持有强势股。'),COLORFF0000 ; 
DRAWTEXT(T23=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.3) 
,'大盘形态良好,但量能稍显不足,随时准备减仓。'),COLORFF0000 ; 
DRAWTEXT(T24=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.3) 
,'大盘趋势不明,注意成交量变化,目前不适宜进场。'),COLORFF0000 ; 
DRAWTEXT(T25=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.3) 
,'大盘趋势向下,量能萎缩,不适合进场。'),COLORFF0000 ; 

6.中线波段王副图

指标概览:

图片[7]来自星星-Www.FromStar.Cn通达信股票指标(更新中)来自星星-Www.FromStar.Cn来自星星

指标说明:K线图中标注明显,简单易看

指标代码:

MA1:MA(CLOSE,5); MA2:MA(CLOSE,10); MA3:MA(CLOSE,20); 

MA4:MA(CLOSE,60); AAF:=LLV(LOW,34),LINETHICK1,COLORFFFFCC; BBF:=MA(AAF,4),LINETHICK1,COLORYELLOW; TYP := (HIGH + LOW + CLOSE)/3; 

CCI1:=(TYP-MA(TYP,6))/(0.015*AVEDEV(TYP,5)); 差值1:=ABS(REF(CCI1,1)-CCI1),LINETHICK0; CCI2:=(TYP-MA(TYP,10))/(0.015*AVEDEV(TYP,10)); 

差值2:=ABS(REF(CCI2,1)-CCI2),LINETHICK0; CCI3:=(TYP-MA(TYP,20))/(0.015*AVEDEV(TYP,20)); 差值3:=ABS(REF(CCI3,1)-CCI3),LINETHICK0; 

CCI4:=(TYP-MA(TYP,30))/(0.015*AVEDEV(TYP,30)); 差值4:=ABS(REF(CCI4,1)-CCI4),LINETHICK0; CCI5:=(TYP-MA(TYP,60))/(0.015*AVEDEV(TYP,60)); 

差值5:=ABS(REF(CCI5,1)-CCI5),LINETHICK0; CCI:=CCI1+CCI2+CCI3+CCI4+CCI5; AAA:=(3*C+H+L+O)/6; 

VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3) +4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36; 

VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3; VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3; 

VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3; VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3; 

VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3; 短线:=VAR1,COLORWHITE; 中线:=VAR6,COLORYELLOW; 

下跌:=IF(VAR1=VAR6,VAR6, DRAWNULL),COLORGREEN; TJ1:= CCI1>差值4; 立桩量:=FILTER(TJ1,0),NODRAW; 

TJ2:=IF(BARSLAST(立桩量)=1 ,1,0); {STICKLINE(立桩量 !=1,REF(HIGH,BARSLAST(立桩量)), REF(HIGH,BARSLAST(立桩量)),1,1),COLORCYAN;} {STICKLINE(立桩量 !=1,REF(LOW,BARSLAST(立桩量)), REF(LOW,BARSLAST(立桩量)),1,1),COLORCYAN;} 

成立1:=TJ2=1; 条件成立1:=FILTER(成立1,5); DRAWTEXT(条件成立1, REF(HIGH,BARSLAST(立桩量)),'看跌'),COLORLIBLUE; 

TJ11:= CCI1<-差值4 ; 

立桩量2:=FILTER(TJ11,0),NODRAW; TJ22:=IF(BARSLAST(立桩量2)=1 AND CLOSE>REF(HIGH,1),1,0); 

突破2:=TJ22=1; {STICKLINE(CLOSE AND 下跌!= VAR6,REF(HIGH,BARSLAST(立桩量2)), REF(HIGH,BARSLAST(立桩量2)),1,1),COLORYELLOW;}

 STICKLINE(CLOSE AND 下跌!= VAR6,REF(LOW,BARSLAST(立桩量2)), REF(LOW,BARSLAST(立桩量2)),1,1),COLORYELLOW; 

TJ:=IF(BARSLAST(立桩量2)=1 AND CLOSE>REF(LOW,1),1,0); 

成立2:=TJ=1; 条件成立2:=FILTER(成立2,5);

 DRAWTEXT(条件成立2,REF(LOW,BARSLAST(立桩量2)),'看涨'),COLORLIMAGENTA;

TJ111:=ABS(CCI1)>CCI AND ABS( 差值1)> ABS(差值5); 

立桩量3:=FILTER(TJ111,3); 

TJ3:=IF(BARSLAST(立桩量3)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(立桩量3)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(立桩量3)=3 AND CLOSE>REF(LOW,3),1,0))); 

成立:=TJ3=1; 条件成立:=FILTER(成立,5); 

DRAWTEXT(条件成立 AND 下跌!= VAR6,L*0.97,'☆成立'); LC:=REF(CLOSE,1); RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100); 

FF:=EMA(CLOSE,3); 

MA15:=EMA(CLOSE,21); 

DRAWTEXT(CROSS(FF,MA15),BBF,'底背离'),COLORA6E500; 

DRAWTEXT(CROSS(88,RSI),(HIGH * 1.01),'顶背离'),COLOR1880FF; {X1:=(C+L+H)/3;BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10; EMA8:=EMA(C,8); DRAWTEXT(FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10), EMA8,'∠45'),COLORWHITE;}; 
© 版权声明
THE END
喜欢就支持一下吧
点赞5
分享
评论一下 抢沙发
来自星星的头像来自星星-Www.FromStar.Cn来自星星

昵称

取消
昵称表情代码图片