Cisco Packet Tracer 笔记·2021.11.14·RIP·OSPF·单臂路由·多端口路由互联

1、RIP路由协议配置

Router(config)#router rip//开启RIP协议

Router(config-router)#network 192.168.1.0//向RIP添加地址

Router(config-router)#version 2//使用RIPv2版本的RIP

1.1、RIP路由协议的理解(和所有相邻的路由器交换信息)

采用跨层设计思想:RIP协议工作在应用层,传输层调用UDP(UDP端口号为520)

RIP 每隔30秒广播形式发送一次路由信息,在邻居之间互传

防止广播风暴:后续分组做随机延时后发送

RIP协议最大有15跳,16跳为不可达(等价无穷大)

如果一个路由在180s内未被更新,相应的距离设置为无穷大:16,并从路由表中删除该表项

2、OSPF路由协议配置

Router(config)#router ospf 100//启用OSPF协议(100:进程号)

Router(config-router)#network 192.168.1.0 0.0.0.255 area 1//宣告网段(0.0.0.255:反码)

Router(config-router)#network 192.168.2.0 0.0.0.255 area 0//宣告网段

2.1、OSPF路由协议的理解(将每一个路由器作为根(ROOT)来计算其到每一个目的地路由器的距离,每一个路由器根据一个统一的数据库会计算出路由域的拓扑结构图)

OSPF:开放式最短路径优先协议

OSPF的简化原理:发Hello报文——建立邻接关系——形成链路状态数据库——SPF算法——形成路由表。

3、单臂路由配置命令

Router(config)#in f 0/0.1 //进入路由器0模块第0端口第1子接口

Router(config-subif)#encapsulation dot1Q 10//封装协议设置为dot1q 允许通过的vlan 为10

Router(config)#in f0/0.2 //进入路由器0模块第0端口第2子接口

Router(config-subif)#encapsulation dot1Q 20//封装协议设置为dot1q 允许通过的vlan 为20

Switch(config)#interface f0/1//进接口

Switch(config-if)#switchport mode access//改为access模式

Switch(config-if)#switchport access vlan 2//划分为vlan2

3.1、单臂路由知识(作用就是一台路由器允许多个vlan互相通信,结构是二层交换机、路由器)

一个VLAN就是一个广播域,划分VLAN就是隔离广播域

4.多端口路由互连VLAN命令

Switch(vlan)#vlan 2

Switch(vlan)#vlan 3

Switch(vlan)#vlan 4

Switch(config)#interface range fastEthernet 0/1-3//1-3同时加入VLAN

Switch(config-if-range)#switchport mode access

Switch(config-if-range)#switchport access vlan 2

© 版权声明
THE END
喜欢就支持一下吧
点赞0 分享
评论一下 抢沙发
头像
说点什么吧~
提交
头像

昵称

取消
昵称表情代码图片