Cisco Packet Tracer 笔记·2021.11.17

明日计划-2021.11.16

三天学习整理,效果不佳,明天开始,专项,逐一突破!

主要项目:

  • DHCP协议
  • 帧中继协议
  • ACL协议
  • RIP协议
  • EIGRP协议
  • HSRP协议

配置PPP

命令:

R1(config)#username ISP password 123class//创建用户名和密码
R1(config)#int s0/0/0
R1(config-if)#no shutdown
R1(config-if)#ip address 60.29.10.1 255.255.255.240
R1(config-if)#encapsulation ppp//在接口上配置PPP协议
R1(config-if)#ppp authentication pap//使用pap认证
R1(config-if)#ppp pap sent-username R1 password 123class

资料来源:CSDNCSDN2

配置DHCP

配置步骤:

1.创建地址池
2.分配的地址池范围
3.配置网关
4.配置dns
5.给路由器端口配置IP
6.如有需要则配置不自动分配的地址段或某个地址

命令:

R3(config)#ip dhcp pool ROOM-1//创建地址池
R3(config)#ip dhcp excluded-address 192.168.22.254//此IP地址不由DHCP分配
R3(config)#ip dhcp excluded-address 192.168.22.1 192.168.22.4//此IP段不由DHCP分配
R3(dhcp-config)#network 192.168.22.0 255.255.255.0//地址池范围
R3(dhcp-config)#default-router 192.168.22.254//默认网关
R3(dhcp-config)#dns-server 192.168.0.100//DNS服务
R3(dhcp-config)#exit

资料来源:CSDN

配置帧中继

命令:

R1(config-if)#int s0/0/1
R1(config-if)#no shutdown
R1(config-if)#ip address 172.31.0.1 255.255.255.0
R1(config-if)#encapsulation frame-relay //封装帧中继协议
R1(config-if)#frame-relay map ip 172.31.0.2 102 broadcast
R1(config-if)#frame-relay map ip 172.31.0.3 103 broadcast

配置FR云:一一映射

ACL配置

命令

R1(config-line)#line vty 0 4

R1(config-line)#access-class ACCESS in

R1(config-if)#int f0/0.33

R1(config-if)#ip access-group ACL in

R1(config)#ip access-list extended ACL//扩展ACL
R1(config-ext-nacl)#deny ip 192.168.33.0 0.0.0.255 192.168.22.0 0.0.0.255
R1(config-ext-nacl)#permit ip any any
R1(config-ext-nacl)#exit
R1(config)#ip access-list standard ACCESS//标准ACL
R1(config-sta-nacl)#permit 192.168.11.0 0.0.0.255
R1(config-sta-nacl)#exit
R1(config)#access-list 55 permit 192.168.11.0 0.0.0.255
R1(config)#access-list 55 permit 192.168.22.0 0.0.0.255
R1(config)#access-list 55 permit 192.168.33.0 0.0.0.255

R1(config)#ip nat inside source list 55 pool network overload

配置RIP

命令:

R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#no auto-summary
R1(config-router)#network 172.31.0.0
R1(config-router)#network 192.168.11.0
R1(config-router)#network 192.168.22.0
R1(config-router)#network 192.168.33.0

配置HSRP

Switch(config)#interface vlan 10

Switch(config-if)#standby 1 ip 192.168.1.254

Switch(config-if)#standby 1 priority 200

Switch(config-if)#standby 1 preempt

EIGRP配置

router eigrp 100 //100为编号,同一个eigrp群中必须一致才可以相互通信

network 192.168.1.0 255.255.255.0  //声名你的接口网段,如果是子网的话,掩码需要是反的

Switch(config-router)#passive-interface vlan 100

Switch(config-router)#no auto-summary//关闭自动汇总

资料:CSDN

GRE配置

Router(config)#interface tunnel 1//进入隧道接口 

Router(config-if)#ip address 172.16.1.1 255.255.255.0//指定IP地址,两端要在一个网段 

Router(config-if)#tunnel source serial 0/0/0//指定承载隧道的源和目的接口 

Router(config-if)#tunnel destination 100.200.1.2

参考资料:CSDN

IPSec VPN配置

Router(config)#crypto isakmp policy 1//配置第一阶段策略

Router(config-isakmp)#authentication pre-share//验证方式为预共享密钥

Router(config-isakmp)#encryption aes//加密算法为aes 

Router(config-isakmp)#group 2//DH组为2

Router(config-isakmp)#exit

Router(config)#crypto isakmp key cisco address 100.200.1.2////配置Key 0 表示不加密,密码为cisco,address 为对端加密点

Router(config)#crypto ipsec transform-set VPN esp-aes esp-sha-hmac//配置第二阶段策略,命名为VPN, esp(加密头部) 加密方式为aes,完整性校验为sha

Router(config)#crypto map R1-R2 1 ipsec-isakmp//定义一个map(名称等本地有效)

Router(config-crypto-map)#set peer 100.200.1.2//指定对端地址

Router(config-crypto-map)#set transform-set VPN//关联第二阶段的策略

Router(config-crypto-map)#match address R1-R2//关联ACL

Router(config-crypto-map)#exit

参考资料:51CTO

其他

SW1(config)#ip routing//三层交换机

SW1(config-line)#login local//vty采用本地用户登录

© 版权声明
THE END
喜欢就支持一下吧
点赞0 分享
评论一下 抢沙发
头像
说点什么吧~
提交
头像

昵称

取消
昵称表情代码图片